ROS Qt Creator Plug-in

Oct 06, 2018






Contents

Installation
FAQ

Users Help
Developers Help

Old Tutorials

13

15

23

25







CHAPTER 1

Installation

1.1 How to Install (Users)

This wiki explains the procedure for installing the ROS Qt Creator Plug-in.

Note: If you primarily want to use this tool for development of other ROS packages (ie: not to work on the plugin
itself), please follow the following instructions.

1.1.1 Installation

Important: The install method has changed from using the ppa method to a custom installer. This is to enable the
ability to provide richer support leveraging existing ros tools which was not possible using the ppa.

Installation Procedure for Ubuntu 16.04

1. Download Installer:
(a) Xenial Online Installer (Recommended)

(b) Xenial Offline Installer

Note: The Offline Installer is to be used on machines that do not have internet access.

2. Next proceed to Ot Installer Procedure

Important: If previously installed using the ppa please follow the procedure below to remove old version.



https://aeswiki.datasys.swri.edu/qtcreator_ros/downloads/installers/xenial/qtcreator-ros-xenial-latest-online-installer.run
https://aeswiki.datasys.swri.edu/qtcreator_ros/downloads/installers/xenial/qtcreator-ros-xenial-latest-offline-installer.run
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sudo apt install ppa-purge

sudo ppa-purge -o beineri

sudo ppa-purge levi-armstrong/gt-libraries—-xenial
sudo ppa-purge levi-armstrong/ppa

Warning: The ppa-purge removes everything installed from the ppa, so if the ppa is used for other development
do not purge.

Installation Procedure for Ubuntu 14.04

1. Download Installer:
(a) Trusty Online Installer (Recommended)

(b) Trusty Offline Installer

Note: The Offline Installer is to be used on machines that do not have internet access.

2. Next proceed to Ot Installer Procedure

Important: If previously installed using the ppa please follow the procedure below to remove old version.

sudo apt install ppa-purge

sudo ppa-purge -o beineri

sudo ppa-purge levi-armstrong/gt-libraries—-xenial
sudo ppa-purge levi-armstrong/ppa

Warning: The ppa-purge removes everything installed from the ppa, so if the ppa is used for other development
do not purge.

Archived Versions

If for some reason you need a version other than the latest, all installers may be found here.

Qt Installer Procedure

1. Then right click on the installer file, select properties and enable execution under permissions.

2. Next double click the installer and it should open and step throught the installer.
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QEt Creator with ROS Plug-in Setup

Setup - Qt Creator with ROS Plug-in

Welcome to the Qt Creator with ROS Plug-in
Setup Wizard.

’

Create Once.
Deploy Everywhere,

vo> ||t
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* Qt Creator with ROS Plug-in Setup

Installation Folder

Please specify the directory where Qt Creator with ROS Plug-in will be
installed.

/home/flarmstrong/QtCreator] Browse...

< Back Cancel
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Qt Creator with ROS Plug-in Setup

Select Components
Please select the components you want to install.

Ot Creator for ROS Install Qt Creator for ROS

¥ || Qt Creator (4.5.1) Development
ROS Plug-in (0.2.1) This component will occupy
approximately 385.11 MiB on
your hard disk drive.

Default Deselect All

< Back Cancel
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Qt Creator with ROS Plug-in Setup

License Agreement
Please read the following license agreements. You must accept the terms
contained in these agreements before continuing with the installation.

Apache License, Version 2.0

GNU GPL version 3 (with exception clauses)

Copyright (c) 2017 ROS Industrial
Contact: https://github.com/ros-industrial/ros_gtc_plugin

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

http:/fwww.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
implied.

See the License for the specific language governing permissions and
limitations under the License.

® | accept the licenses.
| do not accept the licenses.

< Back Cancel
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* Qt Creator with ROS Plug-in Setup

Ready to Install

Setup is now ready to begin installing Qt Creator with ROS Plug-in on your
computer. Installation will use 385.11 MiB of disk space.

Install Cancel
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Qt Creator with ROS Plug-in Setup

Installing Qt Creator with ROS Plug-in

Installing component Qt Creator (4.5.1)
All downloads finished.

Show Details

Cancel
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: Qt Creator with ROS Plug-in Setup

Completing the Qt Creator with ROS Plug-in Wizard

Click Finish to exit the Qt Creator with ROS
Plug-in Wizard.

y

Create Once.
Deploy Everywhere,

1. How to get future updates, open Qt Creator and on the menubar under Help select “Check for Updates™.
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File Edit Debug Analyze Tools window |Help

Check for Updates

ults 3 Application Output 4 Compile Output 5 Debugges

1.1.2 Installation Issues and Conflicts

¢ No known issues

1.1.3 Testing Plugin.

1. Start Qt Creator
* Option 1: Launch using the desktop icon.

¢ Option 2: Launch from terminal.

gtcreator-ros

2. To verify that the plugin exist, goto File>New File or Project>Projects>Other Project>ROS Workspace. If the
ROS Workspace is present then everything built correctly and is ready for development and testing.

1.2 How to Install (Developers)

Note: If you’d like to contribute to the development of the ROS Qt Creator Plug-in, you are considered a developer,
please follow the following instructions.
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1.2.1 Installation

Installation Procedure for Ubuntu 14.04

sudo add-apt-repository ppa:ubuntu-toolchain-r/test

sudo add-apt-repository ppa:levi-armstrong/gt—-libraries-trusty

sudo add-apt-repository ppa:levi-armstrong/ppa

sudo apt-get update && sudo apt—-get install gtb57creator-plugin-ros libgtermwidget57-0-
—dev

Installation Procedure for Ubuntu 16.04

sudo add-apt-repository ppa:levi-armstrong/gt-libraries-xenial

sudo add-apt-repository ppa:levi-armstrong/ppa

sudo apt-get update && sudo apt-get install gt57creator-plugin-ros libgtermwidget57-0-
—dev

1.2.2 Configure system to use the new version of Qt

After installation you need to tell qtchooser where to find this install. Replace the two lines in the file below with the
location to the local version shown below. Make sure to change username and version in the file path to match your
system.

File:

sudo gedit /usr/lib/x86_64-1linux-gnu/qgt-default/gtchooser/default.conf

File content:

/opt/qt57/bin
/opt/qt57/1ib

1.2.3 Run ROS Qt Creator setup script

1. Clone your fork of the repository.

’git clone -b master https://github.com/<username>/ros_gtc_plugins.git

2. Next in a terminal, navigate into the repository directory and execute the command below.

’bash setup.sh —-d

Note: Instruction 2 can can be repeated to get the latest updates for Qt Creator source. The developer must manually
update there fork to get the latest version of ros_qtc_plugins.

1.2.4 Testing Plugin

1. Execute the command below or launch using the desktop launcher.

1.2. How to Install (Developers) 11
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gtcreator

2. To verify that the plugin exist, goto File>New File or Project>Projects>Other Project>ROS Workspace. If the
ROS Workspace is present then everything built correctly and is ready for development and testing.

1.2.5 Debug issues with Plugin

1. Next in a terminal, navigate to the repository ros_gqtc_plugin and execute the command below.

bash setup.sh -di

2. Now launch qgtcreator using gdb as shown below and after the plugin segfaults post the trace back in the ac-
tive/new issue.

gdb <local>/gt-creator-build/bin/gtcreator

(gdb) run
After error:
(gdb) bt
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CHAPTER 2

FAQ

2.1 Frequently Asked Questions

This wiki highlights the frequently asked questions on the issue tracker.
1. How to show empty folders?
2. Are new files automaticly added to the CMakeLists.txt file?

3. Warning: This file is not part of any project.?

2.1.1 How to show empty folders?

By default Qt Creator hides empty folders. In the above image you can see that the workspace src folder is not shown.

Under the project filters uncheck Hide Empty Directories.
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File Edit Build Debug Analyze Tools Window Help
Y ® B =
simplify Tree
v Hide Generated Files
7 Hide Empty Directories

Open Documents

1 Issues 2 Search Results 3 Application Output 4 Compile Output 5 Debugger Console 6 General Messages 9 TestResults &

2.1.2 Are new files automaticly added to the CMakeLists.txt file?

Currently it is the developers responsibility to edit the CMakeLists.txt file.

2.1.3 Warning: This file is not part of any project.?

This can be for several reason.

1. The workspace has not been built from within Qt Creator. Specific flags are passed to cmake which create
specific project files which the IDE can parse to build a code model.

2. The file or files have not been added to the CMakeLists.txt file followed by a build from within Qt Creator.

3. Sometime is persist event if you address the previous items, but if code following is working then it should be
ignored.

14 Chapter 2. FAQ



CHAPTER 3

Users Help

3.1 Setup Qt Creator for ROS

3.1.1 Setup Ubuntu to allow debugging/ptrace

1. Open file: sudo gedit /etc/rc.local
2. Add this line before the exit O line: echo 0 | tee /proc/sys/kernel/yama/ptrace_scope

3. Reboot computer

3.1.2 Set Theme

If version 3.3.1 or higher was installed you are able to set the theme to dark following the steps bellow.
1. Open Qt Creator
2. Goto: Tools >Options >Environment >General

3. There should be a setting for Theme in the “User Interface” group containing a drop down box with two options
“default or dark”.

3.1.3 Set Syntax Color Schemes

1. Open Qt Creator
2. Goto: Tools >Options >Text Editor >Font & Colors
3. There is a drop down box in the “Color Scheme” group where you select different syntax color schemes.
4. Addition schemes can be added as explained in the below links.
(a) https://github.com/welkineins/qtcreator-themes

(b) https://github.com/alexpana/qt-creator-wombat-theme

15


https://github.com/welkineins/qtcreator-themes
https://github.com/alexpana/qt-creator-wombat-theme

ROS Qt Creator Plug-in

3.1.4 Set ROS Code Format

1. Open Qt Creator

2. On the sidebar: Projects >Editor

* Changing it globally at Tools > Options > C++ or within Projects > Code Style does not work.

3.1.5 Setup Clang Formatting

1. Install Clang sudo apt-get install clang-format-3.6
2. Goto: Tools >Options >Environment >External Tools
3. Select: Add > Add Tool
4. Fill in the information below.
¢ Description: Clang Cpp Format
» Executable: /usr/bin/clang-format-3.6

e Arguments:

—true, AllowShortBlocksOnASingleLine: false,
—AllowShortCaselabelsOnASinglelLine: false,

—false, AllowShortFunctionsOnASinglelLine: All,
—AlwaysBreakAfterDefinitionReturnType: false,

—BinPackArguments: true, ColumnLimit: 80, .,

—NamespaceIndentation: None, ObjCBlockIndentWidth: 2

—PenaltyBreakString: 1000, PenaltyBreakFirstLessLess:

—CommentPragmas: 'Y IWYU pragma:', ForEachMacros:

—false}" -1 %{CurrentDocument:FilePath}

—PenaltyExcessCharacter: 1000000, PenaltyReturnTypeOnItsOwnLine: 60
—PointerAlignment: Left , SpacesBeforeTrailingComments: 1
—CppllBracedListStyle: true, Standard: Cppll, IndentWidth: 2, TabWidth: 8,
—UseTab: Never, BreakBeforeBraces: Allman, SpacesInParentheses: false,
—SpacesInSquareBrackets: false, SpacesInAngles: false,
—SpacelInEmptyParentheses: false, SpacesInCStyleCastParentheses: false,
—SpaceAfterCStyleCast: false, SpacesInContainerLiterals: true,
—SpaceBeforeAssignmentOperators: true, ContinuationIndentWidth: 4

—BOOST_FOREACH ], SpaceBeforeParens: ControlStatements, DisableFormat:

-style="{Language: Cpp, AccessModifierOffset: -2, AlignAfterOpenBracket: true,
— AlignEscapedNewlinesLeft: false, AlignOperands: true,
—AlignTrailingComments: true, AllowAllParametersOfDeclarationOnNextLine:

—AllowShortIfStatementsOnASinglelLine: false, AllowShortLoopsOnASingleline:

—AlwaysBreakTemplateDeclarations: false, AlwaysBreakBeforeMultilineStrings:
—~false, BreakBeforeBinaryOperators: None, BreakBeforeTernaryOperators: true,
—BreakConstructorInitializersBeforeComma: false, BinPackParameters: true,

—ConstructorInitializerAllOnOnelLineOrOnePerLine: false,
—ConstructorInitializerIndentWidth: 4, DerivePointerAlignment: false,
—ExperimentalAutoDetectBinPacking: false, IndentCaselabels: false,_
—IndentWrappedFunctionNames: false, IndentFunctionDeclarationAfterType:
—false, MaxEmptyLinesToKeep: 1, KeepEmptyLinesAtTheStartOfBlocks: true,
[
—0bjCSpaceAfterProperty: false, ObjCSpaceBeforeProtocollList: true,_
—PenaltyBreakBeforeFirstCallParameter: 19, PenaltyBreakComment: 300,

120,
Ly
g

[

[

[ foreach, Q_FOREACH,

[

* Working directory: %{CurrentProject:Path}

e Output: Show in Pane

16
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10.

© ® =2 W

¢ Error output: Show in Pane
¢ Environment: No Changes to apply.
* Modifies current document: Checked
Select Apply
Now lets add a quick key.
Goto: Tools >Options >Environment >Keyboard
In the filter box type “Clang” and you should pull up the new tool.
In the Shortcut section enter the Target text box and press Ctrl + Shift + k to setthe shortcut.

Now to apply the Clang format to a C++ file open the file in Qt Creator and press Ctrl + Shift + k and
the file should be formatted correctly.

3.1.6 Preventing Qt Creator form stepping into Boost, Eigen, etc.

. First clone this repository https://github.com/Levi- Armstrong/gdb-7.7.1.git

Follow the instruction in the README file
(a) ./configure
(b) make
(c) sudo checkinstall
Goto: Tools >Options >Debugger > GDB

Add the following code below to the “Additional Startup Commands”

skip pending on
python
for root, dirs, files in os.walk("/usr/include/boost/"):
for file in files:
if file.endswith(".hpp"):
cmd = "skip file " + os.path.Jjoin(root, file)
gdb.execute (cmd, True)

for root, dirs, files in os.walk("/usr/include/eigen3/Eigen/"):
for file in files:
if file.endswith(".hpp"):
cmd = "skip file " + os.path.Jjoin(root, file)
gdb.execute (cmd, True)
end
skip enable

Now when you are stepping through your code it should not step into Boost or Eigen. You can also add additional
directories following the same process.

Also if you would like to skip a particular function refer to the GDB documentation for instruction. It is
something along the lines of skip function function_name.

3.2 How to Import a ROS Workspace

This wiki explains the procedure for importing a ROS Workspace.

3.2. How to Import a ROS Workspace 17
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Note: The pictures may not look identical based on version but the process flow is the same.

3.2.1 User Guide
Step 1

On the Welcome screen select New Project and the following screen should show.
New Project
Choose a template: All Templates

Projects P Ot Unit Test Create ROS Workspace

Application
Library = PlatForm independent
i B3 ot custom Designer widget

Other Project

Non-Qt Project

Import Project Qt Quick Ul Prototype

Files and Classes
Auto Test Project

Subdirs Project

Empty gmake Project

ROS Workspace

Code Snippet

Cancel « Choose...

Step 2

Under Projects select Other Projects > ROS Workspace then select Choose. .. and the following screen
should show.
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Creates New ROS Project

> Project Name and Location ~ Project Name and Location

Name: |
Distribution: kinetic
Build System: CatkinMake

Workspace Path: Browse...

Next = Cancel

Step 3

Fill out the project information.

Field Description
Name Name of the project.
Distribution The ROS Distribution (indigo, kinetic, etc.)

Build System The desired build system.
Workspace Path | The path to the workspace folder.

Step 4

Select Next and the following screen should show and select Finish .

3.2. How to Import a ROS Workspace 19
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Creates New ROS Project

Project Name and Location ~ Project Management
> summary

Add as a subproject to project: <None=

Add to version control: <None> ~ Configure...

Files to be added in

/home/larmstrong/catkin ws/qtc_test:

test.workspace

< Back Finish Cancel

Step 5

The project should be open look similar to the screen below.

File Edit Build Debug Analyze Tools Windo H
Projects $T. @ B <no document>
. v M test
3 B test.workspace
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Step 6 (Optional)

By default Qt Creator hides empty folders. In the above image you can see that the workspace sre folder is not shown.
Under the project filters uncheck Hide Empty Directories.

ebug Analyze Tools Window Help
Y B
simplify Tree
v Hide Generated Files
v Hide Empty Directories

1 Issues 2 SearchResults 3 Application Output 4 Compile Output 5 Debugger Console 6 General Messages 9 TestResults #

3.3 Debugging Catkin Workspace

3.3.1 Prerequisite

1. Allow ptrace by following these instructions

3.3.2 Attach to a unstarted process

1. Next in Qt Creator browse to the file you wish to debug and insert break points.

2. Menu Bar >Debug > Start Debugging>Attach to Unstarted Application...
3. Browse to the executable then select Start Watching.

4. Now run your project. Ctrl + R
5

. Now depending on where the breakpoints were placed in qt, it should be stopped at a break point when it reaches
one.

3.3.3 Attach to a running process

1. Next in Qt Creator browse to the file you wish to debug and insert break points.

2. Now run your project. Ctrl +R

3.3. Debugging Catkin Workspace 21
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3. Menu Bar >Debug > Start Debugging>Attach to Running Application...
4. Now select the Process ID and then click the button Attach to Process.

5. Now depending on where the breakpoints were placed in qt, it should be stopped at a break point when it reaches
one.

Note:

1. Sometime it will be paused at a ros::spin, so check after it has attached and if it is passed and not at a inserted
breakpoint click the continue button in the debugger.

2. Some nodes can execute fast enough to where the debugger is not fully attach to the process before it reaches the
first breakpoint, resulting in it never stopping at the breakpoint. To solve this add a sleep(NumberOfSeconds)
command at the start of the node to allow enough time for the debugger to attach. Usually 3 seconds is enough
but varies depending on the size of the node.

22 Chapter 3. Users Help



CHAPTER 4

Developers Help

4.1 Where to find Qt Creator Plug-in Support

There are three reliable ways to get into contact:

1. There is the bug tracker on bugreports.qt.io. People here are very aware of everything entered there, but may
not react immediately. But this is the best place for feature requests, bug reports and similar things that should
not be forgotten.

2. Our mailing list is actively read by all developers. That is available here which should get most questions
answered.

3. The fastest option is IRC: #qt-creator on the freenode network. All developers hang out there, at least while they
are in the office. So European business hours tend to work best.

Note: This link provides a good overview of names to ping for specific questions.
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CHAPTER B

Old Tutorials

1. How to create a catkin workspace.

2. How to configure the run and build settings.

Note: Videos may not always be up-to-date so if you are not sure about something please refer to the User
Help section.
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