

    
      
          
            
  
Welcome to the ROS Qt Creator Plug-in wiki


Installation



	How to Install (Users)

	Improve ROS Qt Creator Plugin (Developers ONLY)








Users Help



	Setup Qt Creator for ROS

	Debugging Catkin Workspace








Developers Help



	Qt Creator Plug-in Support








Tutorials


	How to create a catkin workspace. [https://www.youtube.com/watch?v=GqBzI7O9h8A]


	How to configure the run and build settings. [https://www.youtube.com/watch?v=5Y9Bz3nh0g0]










          

      

      

    

  

    
      
          
            
  
How to Install (Users)

This wiki explains the procedure for installing the ROS Qt Creator Plug-in.


Note

If you primarily want to use this tool for development of other ROS packages (ie: not to work on the plugin itself), please follow the following instructions.




Installation


Important

The install method has changed from using the ppa method to a custom installer. This is to enable the ability to provide richer support leveraging existing ros tools which was not possible using the ppa.




Installation Procedure for Ubuntu 16.04


	Install Prerequsites:

sudo apt install libqtermwidget5-0







	Next proceed to Qt Installer Procedure





Important

If previously installed using the ppa please follow the procedure below to remove old version.

sudo apt install ppa-purge
sudo ppa-purge -o beineri
sudo ppa-purge levi-armstrong/qt-libraries-xenial
sudo ppa-purge levi-armstrong/ppa






Warning

The ppa-purge removes everything installed from the ppa, so if the ppa is used for other development do not purge.








Installation Procedure for Ubuntu 14.04


	Install Prerequsites:

sudo add-apt-repository ppa:levi-armstrong/qt-libraries-trusty
sudo add-apt-repository ppa:levi-armstrong/ppa
sudo apt install libqtermwidget59-0







	Next proceed to Qt Installer Procedure





Important

If previously installed using the ppa please follow the procedure below to remove old version.

sudo apt install ppa-purge
sudo ppa-purge -o beineri






Warning

The ppa-purge removes everything installed from the ppa, so if the ppa is used for other development do not purge.








Archived Versions

If for some reason you need a version other than the latest, all installers may be found here [https://aeswiki.datasys.swri.edu/qtcreator_ros/downloads/installers/].




Qt Installer Procedure


	Download Installer


	Online Installer [https://aeswiki.datasys.swri.edu/qtcreator_ros/downloads/installers/4.3.1/qtcreator-ros-431-online-installer.run] (Recommended)


	Offline Installer [https://aeswiki.datasys.swri.edu/qtcreator_ros/downloads/installers/4.3.1/qtcreator-ros-431-offline-installer.run]





Note

The Offline Installer is to be used on machines that do not have internet access.





	Then right click on the installer file, select properties and enable execution under permissions.


	Next double click the installer and it should open and step throught the installer.
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	How to get future updates, open Qt Creator and on the menubar under Help select “Check for Updates”.
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Installation Issues and Conflicts


	No known issues







Testing Plugin.


	Start Qt Creator


	Option 1: Launch using the desktop icon.


	Option 2: Launch from terminal.

qtcreator-ros











	To verify that the plugin exist, goto File>New File or Project>Projects>Other Project>ROS Workspace. If the ROS Workspace is present then everything built correctly and is ready for development and testing.










          

      

      

    

  

    
      
          
            
  
How to Install (Developers)


Note

If you’d like to contribute to the development of the ROS Qt Creator Plug-in, you are considered a developer, please follow the following instructions.




Installation


Installation Procedure for Ubuntu 14.04

sudo add-apt-repository ppa:levi-armstrong/qt-libraries-trusty
sudo add-apt-repository ppa:levi-armstrong/ppa
sudo apt-get update && sudo apt-get install qt57creator-plugin-ros libqtermwidget57-0-dev








Installation Procedure for Ubuntu 16.04

sudo add-apt-repository ppa:levi-armstrong/qt-libraries-xenial
sudo add-apt-repository ppa:levi-armstrong/ppa
sudo apt-get update && sudo apt-get install qt57creator-plugin-ros libqtermwidget57-0-dev










Configure system to use the new version of Qt

After installation you need to tell qtchooser where to find this install. Replace the two lines in the file below with the location to the local version shown below. Make sure to change username and version in the file path to match your system.

File:

sudo gedit /usr/lib/x86_64-linux-gnu/qt-default/qtchooser/default.conf





File content:

/opt/qt57/bin
/opt/qt57/lib








Run ROS Qt Creator setup script


	Clone your fork of the repository.

git clone -b master https://github.com/<username>/ros_qtc_plugins.git







	Next in a terminal, navigate into the repository directory and execute the command below.

bash setup.sh -d










Note

Instruction 2 can can be repeated to get the latest updates for Qt Creator source. The developer must manually update there fork to get the latest version of ros_qtc_plugins.






Testing Plugin


	Execute the command below or launch using the desktop launcher.

qtcreator







	To verify that the plugin exist, goto File>New File or Project>Projects>Other Project>ROS Workspace. If the ROS Workspace is present then everything built correctly and is ready for development and testing.







Debug issues with Plugin


	Next in a terminal, navigate to the repository ros_qtc_plugin and execute the command below.

bash setup.sh -di







	Now launch qtcreator using gdb as shown below and after the plugin segfaults post the trace back in the active/new issue.

gdb <local>/qt-creator-build/bin/qtcreator
(gdb) run





After error:

(gdb) bt















          

      

      

    

  

    
      
          
            
  
Setup Qt Creator for ROS


Setup Ubuntu to allow debugging/ptrace


	Open file: sudo gedit /etc/rc.local


	Add this line before the exit 0 line: echo 0 | tee /proc/sys/kernel/yama/ptrace_scope


	Reboot computer







Set Theme

If version 3.3.1 or higher was installed you are able to set the theme to dark following the steps bellow.


	Open Qt Creator


	Goto: Tools > Options > Environment > General


	There should be a setting for Theme in the “User Interface” group containing a drop down box with two options “default or dark”.







Set Syntax Color Schemes


	Open Qt Creator


	Goto: Tools > Options > Text Editor > Font & Colors


	There is a drop down box in the “Color Scheme” group where you select different syntax color schemes.


	Addition schemes can be added as explained in the below links.


	https://github.com/procedural/qtcreator-themes


	https://github.com/alexpana/qt-creator-wombat-theme











Set ROS Code Format


	Open Qt Creator


	On the sidebar: Projects > Editor


	Changing it globally at Tools > Options > C++ or within Projects > Code Style does not work.











Setup Clang Formatting


	Install Clang sudo apt-get install clang-format-3.6


	Goto: Tools > Options > Environment > External Tools


	Select: Add > Add Tool


	Fill in the information below.


	Description: Clang Cpp Format


	Executable: /usr/bin/clang-format-3.6


	Arguments:

-style="{Language: Cpp, AccessModifierOffset: -2, AlignAfterOpenBracket: true, AlignEscapedNewlinesLeft: false, AlignOperands:   true, AlignTrailingComments: true, AllowAllParametersOfDeclarationOnNextLine: true, AllowShortBlocksOnASingleLine: false, AllowShortCaseLabelsOnASingleLine: false, AllowShortIfStatementsOnASingleLine: false, AllowShortLoopsOnASingleLine: false, AllowShortFunctionsOnASingleLine: All, AlwaysBreakAfterDefinitionReturnType: false, AlwaysBreakTemplateDeclarations: false, AlwaysBreakBeforeMultilineStrings: false, BreakBeforeBinaryOperators: None, BreakBeforeTernaryOperators: true, BreakConstructorInitializersBeforeComma: false, BinPackParameters: true, BinPackArguments: true, ColumnLimit:     80, ConstructorInitializerAllOnOneLineOrOnePerLine: false, ConstructorInitializerIndentWidth: 4, DerivePointerAlignment: false, ExperimentalAutoDetectBinPacking: false, IndentCaseLabels: false, IndentWrappedFunctionNames: false, IndentFunctionDeclarationAfterType: false, MaxEmptyLinesToKeep: 1, KeepEmptyLinesAtTheStartOfBlocks: true, NamespaceIndentation: None, ObjCBlockIndentWidth: 2, ObjCSpaceAfterProperty: false, ObjCSpaceBeforeProtocolList: true, PenaltyBreakBeforeFirstCallParameter: 19, PenaltyBreakComment: 300, PenaltyBreakString: 1000, PenaltyBreakFirstLessLess: 120, PenaltyExcessCharacter: 1000000, PenaltyReturnTypeOnItsOwnLine: 60, PointerAlignment: Left , SpacesBeforeTrailingComments: 1, Cpp11BracedListStyle: true, Standard: Cpp11, IndentWidth: 2, TabWidth: 8, UseTab: Never, BreakBeforeBraces: Allman, SpacesInParentheses: false, SpacesInSquareBrackets: false, SpacesInAngles:  false, SpaceInEmptyParentheses: false, SpacesInCStyleCastParentheses: false, SpaceAfterCStyleCast: false, SpacesInContainerLiterals: true, SpaceBeforeAssignmentOperators: true, ContinuationIndentWidth: 4, CommentPragmas:  '^ IWYU pragma:', ForEachMacros:   [ foreach, Q_FOREACH, BOOST_FOREACH ], SpaceBeforeParens: ControlStatements, DisableFormat:   false}" -i %{CurrentDocument:FilePath}







	Working directory: %{CurrentProject:Path}


	Output: Show in Pane


	Error output: Show in Pane


	Environment: No Changes to apply.


	Modifies current document: Checked






	Select Apply


	Now lets add a quick key.


	Goto: Tools > Options > Environment > Keyboard


	In the filter box type “Clang” and you should pull up the new tool.


	In the Shortcut section enter the Target text box and press Ctrl + Shift + k to set the shortcut.


	Now to apply the Clang format to a C++ file open the file in Qt Creator and press Ctrl + Shift + k and the file should be formatted correctly.







Preventing Qt Creator form stepping into Boost, Eigen, etc.


	First clone this repository https://github.com/Levi-Armstrong/gdb-7.7.1.git


	Follow the instruction in the README file


	./configure


	make


	sudo checkinstall






	Goto: Tools > Options > Debugger > GDB


	Add the following code below to the “Additional Startup Commands”

skip pending on
python
for root, dirs, files in os.walk("/usr/include/boost/"):
  for file in files:
    if file.endswith(".hpp"):
      cmd = "skip file " + os.path.join(root, file)
      gdb.execute(cmd, True)

for root, dirs, files in os.walk("/usr/include/eigen3/Eigen/"):
  for file in files:
    if file.endswith(".hpp"):
      cmd = "skip file " + os.path.join(root, file)
      gdb.execute(cmd, True)
end
skip enable







	Now when you are stepping through your code it should not step into Boost or Eigen. You can also add additional directories following the same process.


	Also if you would like to skip a particular function refer to the GDB documentation for instruction. It is something along the lines of skip function function_name.










          

      

      

    

  

    
      
          
            
  
Debugging Catkin Workspace


Prerequisite


	Allow ptrace by following these instructions







Attach to a unstarted process


	Next in Qt Creator browse to the file you wish to debug and insert break points.


	Menu Bar > Debug > Start Debugging > Attach to Unstarted Application...


	Browse to the executable then select Start Watching.


	Now run your project. Ctrl + R


	Now depending on where the breakpoints were placed in qt, it should be stopped at a break point when it reaches one.







Attach to a running process


	Next in Qt Creator browse to the file you wish to debug and insert break points.


	Now run your project. Ctrl + R


	Menu Bar > Debug > Start Debugging > Attach to Running Application...


	Now select the Process ID and then click the button Attach to Process.


	Now depending on where the breakpoints were placed in qt, it should be stopped at a break point when it reaches one.





Note


	Sometime it will be paused at a ros::spin, so check after it has attached and if it is passed and not at a inserted breakpoint click the continue button in the debugger.


	Some nodes can execute fast enough to where the debugger is not fully attach to the process before it reaches the first breakpoint, resulting in it never stopping at the breakpoint. To solve this add a sleep(NumberOfSeconds) command at the start of the node to allow enough time for the debugger to attach. Usually 3 seconds is enough but varies depending on the size of the node.












          

      

      

    

  

    
      
          
            
  
Where to find Qt Creator Plug-in Support

There are three reliable ways to get into contact:


	There is the bug tracker on bugreports.qt.io [https://bugreports.qt.io]. People here are very aware of everything entered there, but may not react immediately. But this is the best place for feature requests, bug reports and similar things that should not be forgotten.


	Our mailing list is actively read by all developers. That is available  here [http://lists.qt-project.org/mailman/listinfo/qt-creator] which should get most questions answered.


	The fastest option is IRC: #qt-creator on the freenode network. All developers hang out there, at least while they are in the office. So European business hours tend to work best.





Note

This link [https://wiki.qt.io/Maintainers] provides a good overview of names to ping for specific questions.
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